Error with keycloack on vps with docker. Invalid parameter: redirect_uri : SOLVED

Hi All,
I installed Openremote on a VPS with Alpine linux as OS.
I used the docker-compose.yml file as proposed by github.

If the deployment takes place on a local machine (my mac) everything works perfectly, if started on the remote virtual machine docker-compose starts correctly but openremote cannot be accessed from the outside.

The login page shows:

“We are sorry …”
“Invalid parameter: redirect_uri”

I tried to set the remote machine address in the command line:

OR_HOST = vps_ip_address OR_SSL_PORT = 443 docker-compose -p openremote up -d

or
OR_HOST = vps_ip_address docker-compose -p openremote up -d

but nothing to do.

How can I correctly configure docker-compose file?

What environment variables should I add or change?

Thanks for your help.

Cocoa

Try without spaces, i.e. OR_HOST=vps_ip_address docker-compose -p openremote up -d

Hi,

it keep doing the same.

Hi,

Seems that the keycloak service has issues if OR_SSL_PORT is the default 443 browsers automatically remove it but then keycloak isn’t happy with the URI…I’ve updated the docker compose files in the openremote repo to exclude OR_SSL_PORT fom KEYCLOAK_FRONTEND_URL environment variable, if you want to run on a different port than 443 then you can uncomment the alternative KEYCLOAK_FRONTEND_URL environment variable.

Hi Rich, issue solved.

Now it’s ok !!

Thank you.

1 Like