How to deploy to the cloud after custom deployment?

After following the instructions User Guide: Custom deployment · openremote/openremote Wiki (, I was able to slightly edit the source code and it worked fine locally. Now how can I deploy them on VMs. I have edited 2 files:

Thanks for help!


As you have edited files in the main openremote repo the custom deployment doesn’t really apply; all you need to do is build your custom manager image:

./gradlew clean installDist
docker build -t openremote/manager:custom ./manager/build/install/manager/

And then you can docker save/load that image to get it to your VM or push the image to your own container repository and load from there.

Just curious what changes you needed to make to those files?

1 Like

Thanks for your attention! I just customized the theme a bit, filtering the assets returned from the server. Right now it’s just that. Maybe more customise soon xD

I have built and pushed to my docker repo, it works fine locally, but when deploying on Azure VM I got the error as shown:

I found the post Container unhealthy _proxy - Custom Deployment - OpenRemote and also tried the fix according to the instructions, but the result is still the same. Can you tell me what I did wrong or what needs to be changed? Thanks for help!

Hi ixxc
Make sure all the 3 lines are there, I had the same issue and fixed it with these lines.
You are looking for:
-line 12 manager-data:
-line 41 - manager-data:/storage
-line 85 - manager-data:/storage

Line numbers are based on

1 Like

Yes, I did. My file:
docker-compose.yml.txt (2.5 KB)

It works when I run it locally. I think the problem is that i ran the update, some old data/configs got conflicted and I’m trying a fresh install from scratch. Thanks for the help!

Differences I found between my yml and yours:
-in postgresql:
I have a volume called - temp-data:/tmp
-Same thing in manager volumes
No idea if it matters, these are the only differences (and ofc replace localhost with your fqdn)

1 Like

Ok, I will double check it. Thank you!

Change the file extension txt---->yml
Extension should be yml

1 Like

I changed it to .txt so I can upload it here, btw thank you xD

bruh, it’s fine now after clean install. I think the problem is the last proxy service with my domain conflict with the new proxy service . Thanks for helping me!

1 Like